Efforts to improve stability of the "Cambrian Wi-Fi" wireless network are ongoing. The technical support case with Cisco has been escalated to the highest severity possible.
Wireless access points across campus have been reset nightly after scheduled classes as part of ongoing troubleshooting with the vendor. Client devices will reconnect automatically. If connection to the "Cambrian Wi-Fi" network is lost clients can toggle their wireless adapters ON/OFF.
Alternatively, clients may connect to the "Cambrian Events" wireless network which will remain available until this issue is resolved.
Posted Jan 22, 2026 - 09:54 EST
Update
Wireless access points across campus will be reset this evening as part of ongoing troubleshooting. Client devices will reconnect automatically.
Posted Jan 16, 2026 - 16:29 EST
Investigating
The IT Service Desk has been informed of intermittent WiFi connectivity and roaming issues across the Barrydowne Campus on the “Cambrian Wi-Fi” network. Clients can still connect but many fail to roam as they traverse the college. IT staff are coordinating with vendor support to troubleshoot and resolve the issue. Further interruptions to WiFi services may occur throughout troubleshooting. We apologize for any inconvenience.
Note:
Wired data services and cellular services are not impacted by this maintenance.