Changes have been completed to the firewall this morning.
Posted Sep 08, 2025 - 08:16 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 08, 2025 - 08:16 EDT
Identified
We’ve received reports of WiFi and network services being degraded throughout campus this morning. Internet connectivity still functions but at significantly reduced speeds for some clients. This is a result of increased demand for internet traffic as students have returned to campus. To mitigate some demand, we have temporarily disabled the “Cambrian-Guest” WiFi network. Staff and Students can still join “Cambrian-WiFi” to connect. We are also changing architecture on our firewalls to increase bandwidth. We are working to expedite completion and apologize for service interruptions throughout the process.
If students have trouble connecting to the “Cambrian-WiFi” network please direct them to the IT Service Desk for assistance.
Thanks for your patience while we work to resolve this issue.